기존에는 1.6까지만 컴파일이 되니. jdk7 플러그인을 새로 깔아야 한다.
아래 내용 참조..(http://wiki.eclipse.org/JDT/Eclipse_Java_7_Support_%28BETA%29)


이클립스가 없다면,  새로 받는다. 
나는 eclipse 대신 Spring Tool Suite를 사용한다. Spring을 쓸 때가 많아서^^;;


 현재 개발중인 jdk 7 auto 컴파일 플러그인을 설치해야 한다.
Help -> New Install Software에

http://build.eclipse.org/eclipse/java7patch/ 

다음 주소를 추가하고 Eclipse Java 7 Support를 다운받는다.



그리고,

프로젝트의 Properties 설정 화면을 띄우고,  Java Compiler에서 compiler compliance level을 1.7로 변경한다.





기존에 1.6 컴파일 방식을 Switch문에 String이 들어갔을 때, 자동 빌드시 에러가 난다.
1.7 컴파일 방식을 사용하니 에러 발생하지 않는다.



jdk 7 테스트 환경 구성 완료.

Posted by 김용환 '김용환'

댓글을 달아 주세요