gradle 에러 내용은 다음과 같다. 



난 여태 gradle은 순서에 상관없는 빌드를 지원하는 것으로 알고 있었다.

그런데 아래와 같은 에러가 발생한다. 


아래와 같이 사용했더니


repositories {
mavenCentral()
}

plugins {
id 'org.springframework.boot' version '2.1.6.RELEASE'
id 'java'
}



아래와 같은 gradle 에러가 발생한다.

only buildscript {} and other plugins {} script blocks are allowed before plugins {} blocks, no other statements are allowed




https://docs.gradle.org/5.4.1/userguide/plugins.html 문서를 참고하면.

plugins (플러그인 바이너리) 스펙에 constraint를 설명하고 있다. 


에러 문구 대로 plugins {} 구문의 앞에는 buildscript {}와 기타 plugin{}만 사용될 수 있다. 





Posted by 김용환 '김용환'

댓글을 달아 주세요