CENTOS 4.7 운영체제를 설치하고 자바 7을 설치했는데, dl (dynamic lib) 에러가 난다. glic 2.4 이상이 설치되어야 jdk 7이 돌아가는 것 같다. Oracle 공식 문서(readme, announcement)에서는 이 부분을 못찾았다.

glic 버전을 확인하니. 2.3이다.

]# ldd --version

ldd (GNU libc) 2.3.4

 

java 1.7.0을 설치했다..

]# java –version
Error: dl failure on line 875
Error: failed /home/www/apps/jdk1.7.0/jre/lib/i386/server/libjvm.so, because /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /home/www/apps/jdk1.7.0/jre/lib/i386/server/libjvm.so)

 

java 1.7.0_03을 설치했다. (wget http://download.oracle.com/otn-pub/java/jdk/7u3-b04/jdk-7u3-linux-i586.tar.gz)

]# java –version
Error: dl failure on line 875
Error: failed /home/www/apps/jdk1.7.0_03/jre/lib/i386/server/libjvm.so, because /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /home/www/apps/jdk1.7.0_03/jre/lib/i386/server/libjvm.so)

 

 

인터넷을 검색하니. “jdk7-b64 has new dependency on glibc-2.4” 이런 내용도 나오구..

http://mail.openjdk.java.net/pipermail/nio-dev/2009-July/000602.html

 

-------------

다른 장비는 CentOS 5.3 이다. glibc는 2.5 이다.

]# ldd --version
ldd (GNU libc) 2.5

 

]# ./java -version
java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) Server VM (build 22.1-b02, mixed mode)

 

리눅스에서 java 7을 사용하려면 glibc 2.4를 쓰는 게 좋을 것 같다.

Posted by 김용환 '김용환'

댓글을 달아 주세요