ubuntu에서 $ apt-get install jenkins 한 후, 새로운 버전으로 설치를 위해 

$ apt-get remove jenkins 하고 


$ apt-get install 하면 아래 에러가 발생



stdout: Reading package lists...

Building dependency tree...

Reading state information...

The following packages were automatically installed and are no longer required:

  libjna-java libcommons-jxpath-java libmaven-dependency-tree-java

  libjaxp1.3-java junit4 gcj-4.6-jre-lib libmaven-plugin-testing-java

  libplexus-archiver-java librhino-java libplexus-containers-java

  libwagon-java libmodello-java gcj-4.6-base libxerces2-java

  libavalon-framework-java libgcj-bc libplexus-classworlds-java

  libmaven2-core-java libhttpclient-java libjffi-jni libcommons-beanutils-java

  libxalan2-java libcommons-jexl-java libjnr-posix-java junit

  libplexus-cipher-java libconstantine-java bsh-gcj libplexus-build-api-java

  libplexus-i18n-java libplexus-interactivity-api-java

  libjenkins-remoting-java libcommons-cli-java java-wrappers

  libmaven-common-artifact-filters-java libcommons-logging-java jenkins-cli

  libxbean-java libcommons-net2-java libmaven-enforcer-plugin-java

  libsaxon-java libgcj12 libitext1-java libplexus-ant-factory-java ant

  libplexus-container-default-java libjsch-java bsh libeasymock-java

  libxml-commons-resolver1.1-java ant-optional fop libbsf-java

  libapache-pom-java libplexus-io-java libplexus-bsh-factory-java

  libclassworlds-java libxml-commons-external-java

  libplexus-interpolation-java libice6 libgoogle-collections-java

  libargs4j-java libanimal-sniffer-java libasound2 libhttpcore-java

  libservlet2.5-java libcommons-httpclient-java libcommons-vfs-java

  libjsr305-java libslf4j-java libasm3-java libjsoup-java libregexp-java

  libfop-java libcommons-configuration-java libxtst6 rhino libjffi-java

  libxmlgraphics-commons-java libcommons-codec-java jenkins-common

  libcommons-lang-java libhamcrest-java libsm6 libnetbeans-cvsclient-java

  libcommons-parent-java libcommons-collections3-java libgcj-common

  libplexus-utils-java libplexus-sec-dispatcher-java libjaffl-java

  libmaven-scm-java libdoxia-java libcommons-digester-java libbatik-java

  libxt6 libbackport-util-concurrent-java libjetty-java liblog4j1.2-java

  libjline-java libcommons-io-java libmaven-invoker-java libganymed-ssh2-java

Use 'apt-get autoremove' to remove them.

The following NEW packages will be installed:

  jenkins

0 upgraded, 1 newly installed, 0 to remove and 169 not upgraded.

Need to get 0 B/61.8 MB of archives.

After this operation, 67.9 MB of additional disk space will be used.

(Reading database ... 56700 files and directories currently installed.)

Unpacking jenkins (from .../archives/jenkins_1.580_all.deb) ...

dpkg: error processing /var/cache/apt/archives/jenkins_1.580_all.deb (--unpack):

 trying to overwrite '/usr/share/jenkins/jenkins.war', which is also in package jenkins-common 1.424.6+dfsg-1ubuntu0.2

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Errors were encountered while processing:

 /var/cache/apt/archives/jenkins_1.580_all.deb


msg: 'apt-get install 'jenkins' ' failed: E: Sub-process /usr/bin/dpkg returned an error code (1)



원인은 jenkins-common은 하위버전, 새로 설치하려는 jenkins 버전은 상위버전이라서 에러가 발생했다. 

그 부분을 보정하니 에러는 더이상 발생하지 않았다. 


$ apt-get remove jenkins-common

$ apt-get install jenkins



Posted by '김용환'

댓글을 달아 주세요